Skip to main content

The MOBILE, MULTIPLAYER, AND MORE Release (version 1.18.32) is Live!




  • Official comment
    Justin Support
    Bug Zapper Support Beacon of Knowledge

    Update 10/26/2022

    We have released a hotfix (version 1.18.42) focused on multiplayer improvements. This hotfix brings improved proxy support for our multiplayer services/URLs and improved in-game multiplayer stability. 

    Hotfix Notes
    How to update

    If you continue to experience multiplayer issues after updating to the hotfix, please reach out to our support team as we're generally able to get to the bottom of these cases through troubleshooting:

    The most common cause of multiplayer issues we're seeing is schools not allowing the new URLs, schools having ephemeral ports blocked, or specific firewall features interacting poorly with our new multiplayer system (such as app decryption). We've also seen some cases where schools can't add the new URL due to inability to add wildcard domains (the * in the URL). If this is the case, the IT Admin guide has our subdomains you can add instead. 

    I'd also like to thank you all for your patience while we've investigated. While some issues may remain, our support team remains ready to help troubleshoot.

    Lastly, I know many of you would like more frequent updates on the forum, and we hear you. We're currently discussing ways we can be more transparent and improve our update frequency. Thank you for your feedback.

    Update 9/13/2022

    For all users whom are experiencing multiplayer issues post 1.18 where it is an entire class, school, or specific OS that cannot join multiplayer, have your IT Admin reach out to us. Generally, this is caused by one of the following issues:

    1. The IT Admin has not allow listed our newest URL through any firewall / content filter / proxy that may block it. 
    2. Their proxy's auto detect is not working with our new URL - We're actively investigating this to see if we can resolve this from our side but would love pcaps from affected devices.
    3. Some IT Admins may need to allow list our TURN services or unblock the use of ephemeral ports. Learn more in the Port section on this article: FAQ: IT Admin Guide – Minecraft: Education Edition Support

    We're happy to look into this and discuss this with your IT Admin through our support desk:  

    We apologize for any class interruption these changes may have brought, hopefully we can get you all back to crafting together soon. Thank you everyone!


    Old Update 8/15/22 11:22AM PST 


    Old Update 8/12/22 1:40PM PST - Known issues:

    • Forum posting is currently down. Posting in existing threads works still. We are investigating this currently.
    • Multiplayer connections are not working as of 11:13AM PST this morning. We're actively investigating. 

    Thank you for your patience while we look into this. For users who had multiplayer connectivity issues before today, this is likely caused by the new URLs not being allow listed by your IT Admin:
    URLs Used by Minecraft: Education Edition – Minecraft: Education Edition Support 

  • Ian Ackerley

    Hi there Penny, the changes look great but it is my understanding is that this update will prevent multiplayer from working in our environment due to our network setup. Ticket #86661

  • Josiah Blaisdell

    Hi there, I am trying to run a class with one of my students and I am not able to. I am hosting the world on a PC and my student is using an ipad. We both just updated to the latest version. When he tries to connect to my world he gets a message that says that the connection timed out. Do you know if there are any issues with the iPad connecting to a PC host? This has always worked in the past .

  • Beth Glynn

    We can't connect via IP addresses any more? Like Ian, our multiplayer has stopped working. Using the connection info will be difficult for little kids.

  • That is bad penny

  • Aleece Landis
    Bug Zapper Beacon of Knowledge Super Star

    How do we get the game to update?  There are 4 computers updated but three that are not.


  • Aleece Landis
    Bug Zapper Beacon of Knowledge Super Star

    Ian Ackerley Look at the connection Info at the bottom of the pause screen (where is used to normally show the IP address and port)  That long connection info number seems to be working for us even though we Used to use IP address and port with port forwarding for our off site students.

  • Danny Support
    Beacon of Knowledge Bug Zapper Support

    Hey Aleece! 

    I saw your ticket you made and made some comments for you over there.

  • Debbie Alexander
    Moderator Beacon of Knowledge Super Star

    My grandchildren will argue over using my phone in the car for the rest of my life!!! =]

    This is awesome!

    I am on a Pixel 2XL Android version 11 (yes I dream of a new phone soon!)

    Here is what my experience was like:

    Download, no problem! Easy, no space issues, easy login. World opened right up. I cannot fly down, only drop.

    In chat, I cannot use the slash from the LHS, I have to type it in. I had no trouble running the chat commands to build the aquarium in the coding world. I had an initial error when I tried to use the armor in the three dot menu, but it only happened once. (message in chat: <error> Something went wrong! <errcode 1>)

    I was able to open the Python AZNB editor. The Agent example code would run. It seemed to me that the editor was incompatible with text input from the **razzum frazzum** text input keyboad on my phone. You know, there's a talk to text mic, and arrows to switch to for digits and special chars... well my summon command looked like garbage. (I have screenies if you like.) I tried resetting, repeatedly. There was no entering text after that.

    I restarted MC:EE. Still busted. I persisted, and the little sidebar appeared, allowing me to select between resizing the window, resetting the code, etc. in a different way. That was the ticket. Now I could enter text again. Timeout error. Bleh. Try, try again. Finally, my first working Python AZNB code in MC:EE on my phone!!!!!

    And in other, unbelievable news, the "This account does not own the skin resource pack" warning is on my phone!

  • Tom Bidstrup

    Multiplayer not working with update. Please fix as soon as possible.

  • Gary Ong

    I teach digital tech in a lab of 27 ethernet connected PCs and our experience with the update so far is that on most computers (win 11) it is extremely slow (laggy) and almost unusable. In task manager I see it using over 90% of CPU even after exiting a world. On a select few it works as expected and the CPU usage is much lower (around 30%). 

  • Zoha Aleem Baig

    my minecraft education is not even updating its still 1.17.32 i tried restarting my macbook multiple times but still its not updating 

  • Zoha Aleem Baig

    i wish i can play the new update it sounds more cooler

  • Marius Fernandez

    j'aime bien les nouveautés mais ma limite de distance d'affichage a été grandement réduite et je trouve ça dommage. 

  • Bryan Sanders
    Bug Zapper Beacon of Knowledge Super Star Moderator

    I’m having trouble signing in. I know my username and password, and I have Microsoft Authenticator on my iPhone. So, I put in user and password. Then the Authenticator asked for my face to unlock and approve the sign in request. I do that. And then switch back to MinecraftEdu, but it doesn’t remember where I left off in the sign-in process and I have to start again.
    Undaunted, I do so. This time I try the text message for the 2fa and after I put that in it tells me something went wrong.
    So, I headed over here to report my findings.

  • Marius Fernandez

    je pense qui faudrait un moyen de changer de version du jeu pour re venir a une version plus stable. 

  • Tyreece Rozycki

    This is very frustrating for us as we have been using the connect via ip method for our schools.

    Is there any explanation on how connect by id works? Does it internally use the ip address?
    Any documentation for this new feature?

    And is there an explanation on why ip connection was removed?


  • Debbie Alexander
    Moderator Beacon of Knowledge Super Star

    Zoha Aleem Baig Updates on a mac are manual. You have to back up your worlds, and download.

    Tom Bidstrup Gary Ong Thanks for reporting, bu t sorry for the trouble! Did you remember to adjust the url allow list? (link below.)

  • Josef Hamling

    The install does not work on Mac. Previous version worked yesterday but when I try to install the 1.18.32 I get an error message ant the install cannot be completed. I've tried to restart, uninstall, etc. My son is in the middle of a programming course and we cannot proceed as it is now.


    Here is the error message:

    Process:               minecraftpe [619]

    Path:                  /Applications/

    Identifier:            minecraftpe

    Version:               1.18.32 (

    Code Type:             X86-64 (Native)

    Parent Process:        ??? [1]

    Responsible:           minecraftpe [619]

    User ID:               501


    Date/Time:             2022-08-11 11:31:55.548 +0200

    OS Version:            Mac OS X 10.14.6 (18G9323)

    Report Version:        12

    Anonymous UUID:        689A418E-737D-BB41-3A41-FCEA0F6BD963



    Time Awake Since Boot: 640 seconds


    System Integrity Protection: enabled


    Crashed Thread:        0


    Exception Type:        EXC_CRASH (SIGABRT)

    Exception Codes:       0x0000000000000000, 0x0000000000000000

    Exception Note:        EXC_CORPSE_NOTIFY


    Termination Reason:    DYLD, [0x4] Symbol missing


    Application Specific Information:

    dyld: launch, loading dependent libraries


    Dyld Error Message:

      Symbol not found: ___darwin_check_fd_set_overflow

      Referenced from: /Applications/

      Expected in: /usr/lib/libSystem.B.dylib

    in /Applications/


    The New Update Wont allow me to Play Multiplayer When Either me and my brother host it shows the charecters which does not work always times out and the other info it shows connection info in the join but when we host it shows IP adress not connection info please fix it ASAP

  • Jude Flores Juro

    I am on a chromebook from school and trying to update minecraft education edition to minecraft 1.19 update but a don't know how to? Please tell me how to download the 1.19 update.

  • Patrick Plumlee

    Today I logged onto Minecraft Education Edition and realized that it was updated to 1.18. This was very exciting until I tried to join my brother on our Hermitcraft series. So I clicked the join world tab and went into the place where you could stick in the IP address. I had memorized this IP address and could type it in very quickly. Except it said information code, I thought this number would be similar to an IP address, but when my brother pulled up the multiplayer option on the pause screen, I was surprised to see that it was a very long number. So I thought to myself “would I really type in a number that long?” No. So I took a picture, and copied the number, and stuck it into the right place. What I thought would take seconds took almost 2 minutes, or at least it felt like it. And then it showed me to a screen that said “connection timed out” I tried this multiple times all with the same result. And then I tried googling what this means and all I got was it trying to tell me that something was blocking access to the multiplayer game. The only problem was I had absolutely no idea how to get rid of some sort of the firewall. I thought for a while until my brother suggested that I use the join code. After that point I thought I was brain dead and didn’t think hard enough so I also tried the join code. 2 minutes later same result and that’s exactly how I got here. I’d advise the devs to add the IP address back in and fix the multiplayer problem. Anyways…yeah.

  • David Laursen

    Multiplay on Version 1.18.32 is not broken.  It works when hotspotting devices to a mobile phone.  It must be an internet access issue though our school internet filter.

  • Danny Support
    Beacon of Knowledge Bug Zapper Support

    Jude Flores Juro

    Thanks for writing in! If Minecraft: Education Edition did not automatically update for you, make sure to back up your worlds, uninstall Minecraft: Education Edition and reinstall from our website: 


    Let us know how it goes!

  • Danny Support
    Beacon of Knowledge Bug Zapper Support

    Josef Hamling

    Thanks for your report, and sorry to hear! I passed it along to the team and will let you know any updates.

  • Cheyenne Weimer

    It’s not letting me join my friend. Like the codes, connect info isn’t working. We’ve reloaded it many time but it’s not working!


    Whenever One of my friends try to join it shows connection timed out on the other computer and on my computer it says error code something went wrong error code (1) and my internet 

  • Hi
    Multiplayer not working with update. Please fix as soon as possible.

  • Hello my iPad minecraft edu is displaying a message in chat I don’t know what it means but if anyone can tell what it is then I would be very great full.

    picture of message:

  • Danny Support
    Beacon of Knowledge Bug Zapper Support

    Hey all! 

    For those experiencing multiplayer connection issues, please see the currently pinned comment above.

    The team is aware and actively investigating. Thank you for your patience!


Post is closed for comments.