Skip to main content

No idea why things worked today



  • Moderator Beacon of Knowledge Super Star

    It's a challenge. The overwhelming experience is that the students are so motivated they will keep trying. OTOH they can be massively disappointed when planned events don't work. Somehow they console themselves with some build time, lol. I have had random computers just completely lose the software (with worlds.) I sing the "back it up if you care about it" song all the time. Sometimes they run into the wall of reality when they really do lose something. I dream of a better computing environment, but between all the tech glitches, and student confusion and updates, I think it is part of the landscape for the rest of my career, at least.

    lol Super encouraging, ~not~, I suppose. I take heart from being on the path with educators I admire, and learning from them. Thanks for being one of them.

  • Bug Zapper Beacon of Knowledge Super Star

    Bryan Sanders I'll go out on a limb here and say, I'm sure some of the problems the first week or so after the initial release, Had to have been from communication issues for things "NOT UNDER END USER CONTROL" as in issues with the updates to whatever "services" are required to let these things work, since in many cases, there hasn't been an additional update pushed out on the software and in many cases, nothing new has been done to the networks or their security/firewall rules etc.

    Hope it all keeps working

  • Justin Support
    Bug Zapper Support Beacon of Knowledge

    Glad to hear things are working today!

    I guarantee that the team has heard the feedback from the community and we're not pleased with how this update or the v1.18 update affected classrooms. Outside of working to resolve the current problems, we're also focusing on getting together to see how we can ensure disruptions like this do not happen again. 

    One thing we'll be trying to push more in the future is a greater level of beta usage which will help catch issues that happen in specific school network environments. 

    As for it randomly working, we've made no changes on our side yet. I've been hearing similar reports in tickets and my only guess is that one pesky user somewhere was still on v1.18 and attempting to log into the v1.19 world and bugging out the host. If that isn't it, I'm not quite sure, I suppose maybe network level smart firewall / smart antivirus that is no longer interfering (as those types can auto block services it deems untrustworthy for a number of reasons). 

    With that said, we are doing a server side change next week which will prevent v1.18 users from attempting to connect to v1.19 worlds. We're continuing to investigate and develop further fixes to make this update more stable. Thank you again for your feedback, we're listening. 

  • Debbie Alexander well put- I find that my students will happily spend the whole class period troubleshooting it, especially because they get weird glimpses of success with this super unstable current build. I've done a lot of work with modpacks and custom content in large scale multiplayer server management, and making sure that a build is stable for the use case it's being rolled out to is something I hope that the development and launch folks at Minecraft as well as support improves on in the future. Would love to see a hotfix and patch notes log with some more oomph to it, as the current model leaves a bit to be desired if you're really curious about what is going on at a technical level. Generalities like 

    • "Updated Sign-In Experience" 

    in a list of bullet points without information about what is being changed caused problems at my school. It seemed like there was some additional traffic on a URL that our network admins and firewall provider noticed after the update. That was resolved, but then suddenly last friday we lost connection mid session and have not been able to host a multiplayer session since that abrupt disruption of service. It was a bit glitchy before that, but usually restarting chromebooks relogging fixed the issues we were having. I am not sure what happened then, but perhaps a patch was pushed out? Hard to tell.

    It has been a good platform for me to talk about troubleshooting as a concept, telling stories of game nights and LAN parties gone awry because of connectivity issues or sudden patches from a game, but no student wants to learn those lessons when compared with exploring ancient egypt or building a redstone door. The most frustrating part for them is that there is nothing that they can do most of the time to fix it, and they look to me to do it, and I do not have additional things we can try. We have also inexplicably lost worlds before, so I encourage my kids to back their worlds up on google drive, but that eats into their already brief time and so some opt to risk it.

    It's puzzling to me Justin that even when I ensure that all of the users are on 1.19.52, there are still issues hosting multiplayer worlds. Is there a fix in the works for the issue that prevents users from joining each other even when there is no version sync issue present, and if so, what is it?


  • Moderator Beacon of Knowledge Super Star

    As a "pretty good report" comment: 

    I have 11 students all in a student shared world, with lots of command blocks and stuff but no code, with no problems except that when the student host tries to change the player permission to operator the window super fast, and he has to rush to click quickly enough to change it.

    End of the year projects in full swing!


  • Similar issues with the new update. But, there seems to be a small workaround with the Mac version. Delete the old app and reinstall fresh the new version 1.19.52. Restart the Mac and things are now working a bit better. Still get the occasional issue, but at least the students can get in and interact.

    Not too sure if a similar "wipe and reinstall" would work with the Windows version, but it could be worth a shot.


Please sign in to leave a comment.